среда, 22 февраля 2017 г.

Опция Random в Firewall Mikrotik - имитация плохого соединения.

  Иногда нужно симитировать плохое соединение с Интернет. Причины могут быть разные, например "вредный пользователь".
  WiKi Mikrotik так объясняет эту опцию.


  По факту, опция указывает в процентном соотношении количество пакетов для которых будет применяться данное правило.
  Для примера создадим правило, которое будет имитировать потерю пинга на сервер 8.8.8.8 в 20%.




  Само правило:
/ip firewall filter
add action=drop chain=forward dst-address=8.8.8.8 protocol=icmp random=20
  Результат:

  
Аналогично можно блокировать, допустим, доступ на веб-сервисы, или вообще на все tcp-соединения.
/ip firewall filter
add action=reject chain=forward dst-port=80 protocol=tcp random=50 reject-with=icmp-network-unreachable src-address=192.168.88.27
  Представленное правило блокирует 50 процентов запросов с ip 192.168.88.27 на 80 порт.


Используемый материал:

Подписаться на новые статьи.

1 комментарий:

  1. Я надеюсь автор блог не забросил? очень классные и полезные статьи

    ОтветитьУдалить