воскресенье, 15 ноября 2015 г.

Один внешний IP и несколько WEB-серверов внутри сети.

                     Это работает только для HTTP-соединений но не работает для HTTPS соединений, так как web-proxy такие соединения не поддерживает

  У нас есть один внешний IP, за которым мы хотим поместить несколько WEB-серверов(в данном случае 3, с 3 разными доменами на них):
123.com@192.168.0.2
 abc.com@192.168.0.3
 456.com@192.168.0.4
   Настраиваем наш прокси-сервер:
/ip web-proxy
set enabled=yes src-address=0.0.0.0 port=8080 hostname="your.proxy" \
transparent-proxy=yes parent-proxy=0.0.0.0:0 \
cache-administrator="webmaster" max-object-size=4096KiB cache-drive=system \
max-cache-size=unlimited max-ram-cache-size=unlimited
/ip web-proxy access
add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \
disabled=no
add dst-port=80 action=allow comment="Enable Http Connection" disabled=no
  Настраиваем статические ДНС записи:
/ip dns static add name=123.com address=192.168.0.2
/ip dns static add name=abc.com address=192.168.0.3
/ip dns static add name=456.com address=192.168.0.4
/ip dns static add name=www.123.com address=192.168.0.2
/ip dns static add name=www.abc.com address=192.168.0.3
/ip dns static add name=www.456.com address=192.168.0.4 
  Конфигурируем NAT для перенаправления на наш веб-прокси:
 /ip firewall nat
add chain=dstnat in-interface=outside dst-address=xxx.xxx.xxx.xxx protocol=tcp \
dst-port=80 action=redirect to-ports=8080 comment="" disabled=no 
  Трафик для 123.com будет выглядеть так:
 Интернет -> xxx.xxx.xxx.xxx:80 ---> xxx.xxx.xxx.xxx:8080 -> 192.168.0.2:80 
  Веб-прокси будет перенаправлять трафик 123.com на внутренний адрес IP-192.168.0.2.

  Не забываем оставить доступ к нашему прокси-серверу по определенным URL(нашим легитимным) в противном случае наш маршрутизатор может быть использован для перенаправления трафика на сайты за пределами сети:
/ip proxy access
add dst-port=80 dst-host="123.com" action=allow disabled=no
add dst-port=80 dst-host="abc.com" action=allow disabled=no
add dst-port=80 dst-host="456.com" action=allow disabled=no
add action=deny disabled=no 

Перевод:
http://wiki.mikrotik.com/wiki/Multiple_Web_Servers 

Подписаться на новые статьи.

Комментариев нет:

Отправить комментарий