пятница, 30 октября 2015 г.

Доступ в Mikrotik по двум и более WAN одновременно.

На нашем устройстве два или более провайдера интернет(WAN). Нам нужно что-бы наше устройство было доступно и с одного и с другого внешнего IP провайдеров одновременно.
[admin@mikrotik] /ip firewall mangle> print
Flags: X - disabled, I - invalid, D - dynamic
0 chain=input action=mark-connection new-connection-mark=ISP 1 -> Input passthrough=no dst-address=172.25.25.247 in-interface=ether1
1 chain=output action=mark-routing new-routing-mark=ISP 1 passthrough=no connection-mark=ISP 1 -> Input
2 chain=input action=mark-connection new-connection-mark=ISP 2 -> Input passthrough=no dst-address=192.168.99.2 in-interface=ether2
3 chain=output action=mark-routing new-routing-mark=ISP 2 passthrough=no connection-mark=ISP 2 -> Input
4 chain=input action=mark-connection new-connection-mark=ISP 3 -> Input passthrough=no dst-address=192.168.100.2 in-interface=ether3
5 chain=output action=mark-routing new-routing-mark=ISP 3 passthrough=no connection-mark=ISP 3 -> Input
  Правило 0
  Если в пакете пришедшем на первый интерфейс (ISP 1) в адресе назначения указан IP адрес 172.25.25.247(ISP 1, ip от провайдера), то маркируем соединение именем (ISP 1 -> Input)
  Правило 1
  Если исходящий пакет принадлежит соединению с маркировкой (ISP 1 -> Input), то для него используем маршрут ISP 1
  Тем самым маршрутизатор знает, что если его (пингуют или любой входящий трафик) с провайдера ISP 1, то ответ вернёт он через провайдера ISP 1

  Соответственно нужно создать нужные нам маршруты:
add comment=ISP1_mark distance=1 gateway=192.168.111.1 routing-mark=ISP 1
add comment=ISP2_mark distance=1 gateway=82.117.240.1 routing-mark=ISP 2
где  gateway - шлюз по-умолчанию вашего провайдера.

Подписаться на новые статьи.

2 комментария:

  1. Спасибо, Жень, пригодилось =) Сам я не додумался, как это рализовать..
    Единственное, у меня динамический адрес, по которому я хочу лазить на МТ, посему написал такой скрипт для обновления адреса в правиле:

    :global utip [ip address get [/ip address find interface=utppoe] address ];
    :global mangleip [ip firewall mangle get [/ip firewall mangle find comment="utel_input" ] dst-address ];

    #:log info ("$utip")
    #:log info ("$mangleip" )

    :if ($utip = $mangleip ) do={ :log info ("ip in rule is OK" ) } else={ ip firewall mangle set [/ip firewall mangle find comment="utel_input"] dst-address=$utip ; :log info ("RENEWING COMPLETE" )}

    ОтветитьУдалить
    Ответы
    1. была у нас дискуссия по этому поводу, но тогда мы пришли к выводу что основной шлюз у роутера может быть только один, про маркировку не подумали...

      Удалить