суббота, 18 апреля 2015 г.

Отслеживание нагрузки на CPU и оповещение по e-mail.

Скрипт:
:global cpu1 [/system resource get cpu-load];
:delay 120;
:global cpu2 [/system resource get cpu-load];
:local time1 [/system clock get time];
:local body1 "$time1 Mikrotik over 91% CPU";
if ((($cpu1) >= 91) and (($cpu2) >= (91))) do={/tool e-mail send server=[:resolve "smtp.yandex.ru"] port=587 user=any@i.ua password=pass start-tls=yes to="any@i.net.ua" from=any@net.ua subject="Mikrotik" body="$body1"; /system scheduler disable schedule_cpu} else={}

Можно отправлять одному и тому же адресату(отправитель=получатель), можно отправлять на услугу "смс с e-mail".
 Скрипт при удачном выполнении сам себя выключает, включить его можно вручную или другим скриптом.

Подписаться на новые статьи.

Комментариев нет:

Отправить комментарий